Issue 1
A timeout occurred error.
Overview
This error indicates that a user has sent a request to the server but the server could not deliver the results within a certain timeframe and the request timed out.
Common cause
This error usually happens when you are trying to generate a report in SchoolMind which contains a huge amount of data. For example, a report that is containing data for 2, 3, or 4 consecutive academic years or similar. In order to generate these huge reports the server needs more time than set by Cloudflare policy, and it can result in a timeout.
Solution
Generate reports for shorter time periods and then merge them. For example, generate reports for each academic year separately and then merge them into a single file.
Even though error such as this happens rarely, we are constantly working on optimizing SchoolMind so users don't encounter these issues.
If this is not a good solution for you at the moment, open a ticket on our Help Center portal using this link.
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Issue 2
Blocked by Cloudflare error.
Overview
SchoolMind is using Cloudflare to protect itself from online attacks. If a user performs an action that triggers Cloudflare's firewall, the user will be blocked from accessing the SchoolMind web app.
Common cause
If a visitor is getting "blocked by Cloudflare" message while trying to access SchoolMind, this means that the user is triggering a rule in the Web Application Firewall (WAF) instructing Cloudflare to block the user. There are several actions that could trigger the block including submitting a certain word or phrase, a SQL command or malformed data.
Solution
If you believe this is an error, open a ticket on our Help Center portal using this link and include the following:
- The data you were sending
- The URL
- The time when it happened
- Cloudflare Ray ID (shown at the bottom of the error page)
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